Yesterday, I was holding a development conventions meeting with all developers at Visionmap. It was an interesting discussion with many humorous highlights.
At one point during discussion of variable, function and project naming strategies, it was suggested by VadimK that keyword "Utils" should be banned in library names, or they drift into becoming garbage cans. Some raised concerns what happens when you don't place a garbage can in a certain area. Then someone raised the issue of "New" keyword in function names.
Was it in Futurama where they had "New New York" and the old city of the future new york was named "Old New York"? (Base one numerals - says VZ). Then, LevB told us they have two functions named something like ComputeTransformationMatrix() and ComputeTransformationMatrixCorrectly().
(a typical situation which would happen when one doesn't want to risk breaking 128 other working projects, during a war)
RoieM: "This is surely very bad. It should have been a boolean parameter! :)"
LevB: "With a default - false."